Cloudflare System Status

Errors and timeouts accessing cloudflare.com and APIs
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Apr 24, 2015 - 17:01 UTC
Monitoring
The stability of cloudflare.com and APIs has been restored. We are closely monitoring.
Posted Apr 24, 2015 - 16:32 UTC
Investigating
We are currently investigating this issue.
Posted Apr 24, 2015 - 15:10 UTC