Cloudflare System Status

Cloudflare Pages GitHub users build issues

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Mar 27, 2023 - 13:35 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 27, 2023 - 13:29 UTC

Investigating

Cloudflare is aware of and investigating an issue with Cloudflare Pages build delays which potentially impacts multiple customers. GitHub users may fail to push changes to their repos which means they can't create new Pages deployments. GitLab users are unaffected. Live edge traffic is unaffected. Further updates to follow.
Posted Mar 27, 2023 - 12:44 UTC
This incident affected: Cloudflare Sites and Services (Pages).