Cloudflare System Status

Registrar delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jul 22, 2021 - 12:38 UTC
Investigating
Cloudflare is aware of, and investigating an issue which potentially impacts multiple customers on Registrar - new registration operations, which may be delayed in processing.
Further detail will be provided as more information becomes available.
Posted Jul 22, 2021 - 12:32 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Registrar).