Cloudflare System Status

Network Analytics Issues

Incident Report for Cloudflare

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 25, 2026 - 15:57 UTC

Investigating

Cloudflare has identified an issue causing Spectrum Analytics to not displaying correctly within the dashboard.

Service traffic and protection remain unaffected as this is a reporting-only delay.
Posted Mar 25, 2026 - 12:32 UTC
This incident affects: Cloudflare Sites and Services (Analytics).