Cloudflare System Status

Elevated Latency for R2 Customers in APAC / ENAM

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 23:12 UTC

Investigating

We are investigating an issue causing elevated latency for R2 customers in APAC and ENAM. Cross-region requests between these regions may see elevated response times.
Posted Oct 21, 2025 - 22:02 UTC
This incident affected: Cloudflare Sites and Services (R2).