Cloudflare System Status

Customer may experience issues ordering services or adding/updating their payment methods (slowness and timeouts).
Incident Report for Cloudflare
Resolved
Cloudflare has resolved the issue and services have resumed normal operation.
Posted Dec 24, 2020 - 22:44 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 24, 2020 - 21:54 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 24, 2020 - 21:53 UTC
Investigating
We are investigating some latency in order processing that is causing some delays.
Posted Dec 24, 2020 - 21:43 UTC
This incident affected: Cloudflare Sites and Services (Billing).