Cloudflare System Status

Issues with filing Cloudflare's abuse reports

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Feb 03, 2021 - 05:38 UTC

Identified

Team has identified the root cause and working on deploying fix
Posted Feb 03, 2021 - 04:22 UTC

Investigating

Cloudflare's Abuse Submission Form is currently experiencing issues and reports may not be accepted.
Posted Feb 03, 2021 - 03:27 UTC