We are continuing to monitor for any further issues.
Posted Apr 03, 2026 - 17:18 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 03, 2026 - 17:18 UTC
Identified
Cloudflare has identified an issue impacting Cloudflare Pages deployments of Pages Functions with R2 bindings. Customers may experience failures deploying their Pages Functions
We are working to analyze and mitigate this problem. More updates to follow shortly.
Posted Apr 03, 2026 - 16:50 UTC
This incident affected: Cloudflare Sites and Services (Pages).