Cloudflare System Status

API Tokens for R2 buckets access issue

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Jun 14, 2024 - 22:38 UTC

Update

We've deployed a fix to our IAM propagation improving message throughput, and the message queue is currently decreasing.
Posted Jun 14, 2024 - 17:56 UTC

Identified

We've identified an issue with token propagation affecting API token delegation to the R2 service. Newly created tokens will be delayed in functioning. We're working to resolve the issue, and tokens created will begin functioning properly once resolved.
Posted Jun 14, 2024 - 14:44 UTC

Investigating

Cloudflare is investigating a problem in token authentication for newly created API token for R2 buckets access. Existing tokens will work as usual.
Posted Jun 14, 2024 - 14:06 UTC
This incident affected: Cloudflare Sites and Services (R2).