Cloudflare System Status

Degraded latency for Durable Objects and R2 buckets in WNAM

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted May 19, 2026 - 10:05 UTC

Update

We are continuing to investigate this issue.
Posted May 19, 2026 - 08:23 UTC

Update

We are continuing to investigate this issue.
Posted May 19, 2026 - 08:14 UTC

Investigating

Durable Objects and R2 buckets in WNAM may see increased latency, reduced throughput and slightly increased error rates.
Posted May 19, 2026 - 08:13 UTC
This incident affected: Cloudflare Sites and Services (Durable Objects, R2).