Major ImpactLast updated: Refreshed just now
Increased Error Rates in North America West
Started
Resolved
Timeline
- Resolved
This incident has been resolved.
- Updated
We are continuing to investigate this issue.
- Investigating
Users may experience increased error rates when interacting with Cloudflare services in the Seattle region.