Cloudflare System Status

DNS Update Delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted 26 days ago. Sep 26, 2019 - 13:50 UTC
Update
The current delay for updates to DNS records is 1h 20min. We are continuing to work on a fix for this issue.
Posted 26 days ago. Sep 26, 2019 - 13:19 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 26 days ago. Sep 26, 2019 - 12:45 UTC
Investigating
Cloudflare is investigating delays for updates to DNS records. This delay also affects provisioning SSL certificates and new Argo Tunnel instances.

DNS resolution, existing SSL certificates, and established Argo Tunnels are not impacted.
Posted 26 days ago. Sep 26, 2019 - 12:04 UTC
This incident affected: Cloudflare Sites and Services (DNS Updates).