Cloudflare System Status

Cloudflare Billing: Dashboard and Cloudflare API service issues

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Sep 30, 2025 - 11:32 UTC

Monitoring

Cloudflare detected and mitigated issues with Cloudflare Dashboard and related APIs: Customers might have observed errors or unexpected behavior when attempting to perform Billing operations.
These issues did not affect the serving of cached files via the Cloudflare CDN or other security features at the Cloudflare Edge.
A fix has been implemented and we are monitoring the results.
Posted Sep 30, 2025 - 11:09 UTC
This incident affected: Cloudflare Sites and Services (API, Billing, Dashboard).