Cloudflare System Status

Durable Objects Failing To Wake From Hibernation

Incident Report for Cloudflare

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 04, 2025 - 07:58 UTC

Update

We are reverting a change that coincides with this issue. The rollback is currently in progress.
Posted Jul 04, 2025 - 06:52 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 04, 2025 - 03:23 UTC

Identified

Some Durable Objects using the WebSocket Hibernation API are failing to call WebSocket::send() after waking from hibernation, which is preventing WebSocket messages from being delivered to clients.
we are now rolling out a fix.
Posted Jul 04, 2025 - 01:02 UTC

Investigating

We are investigating reports of Durable Objects having issues waking from Websocket hibernation.
Posted Jul 03, 2025 - 22:37 UTC
This incident affects: Cloudflare Sites and Services (Durable Objects).