A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2026 - 08:43 UTC
Investigating
Cloudflare is investigating network performance issues that may impact a subset of users in Mumbai, India. Some users may experience increased latency or intermittent errors. We are actively working to mitigate this problem. More updates to follow shortly.
Posted Mar 19, 2026 - 08:37 UTC
This incident affected: Asia (Mumbai, India - (BOM)).