Cloudflare System Status

Load Balancing Configuration Propagation Delayed

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Jul 22, 2025 - 00:39 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 22, 2025 - 00:10 UTC

Investigating

We are investigating an issue where edits and creation of new Load Balancers are experiencing extended delays in propagating to the our edge network.
Posted Jul 21, 2025 - 23:57 UTC
This incident affected: Cloudflare Sites and Services (Load Balancing and Monitoring).