Cloudflare System Status

Cloudflare Speed Page Issues
Incident Report for Cloudflare
Resolved
Cloudflare has resolved the issue and services have resumed normal operation.
Posted Nov 16, 2020 - 21:00 UTC
Identified
Cloudflare has identified the issue and is implementing a fix.

We will update the status once we implement the fix.
Posted Nov 16, 2020 - 16:03 UTC
Investigating
Cloudflare is aware of an issue preventing the running of new speed tests.
We are investigating the issue, and will update here when more information is available.
Posted Nov 16, 2020 - 15:14 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Dashboard).