Last updated: Refreshed just now
Cloudflare Dashboard and API Maintenance
Started
Completed
Timeline
- Completed
The scheduled maintenance has been completed.
- In Progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
- Updated
Maintenance will begin as scheduled in 60 minutes.
- Updated
We will be undergoing scheduled maintenance during this time.
- Scheduled
We will be conducting routine maintenance on the Cloudflare Dashboard (https://dash.cloudflare.com) and API (https://api.cloudflare.com) on July 22nd, 2020 from 18:00 - 19:00 UTC. During this 1 hour maintenance window the Cloudflare Dashboard and API may be degraded or unavailable as we are implementing resilience improvements. We will update as soon as this maintenance window expires.