Cloudflare System Status

Possible Network Congestion Across Multiple Regions
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Feb 15, 2022 - 19:53 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 15, 2022 - 18:54 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 15, 2022 - 17:59 UTC
Update
We are continuing to investigate this issue.
Posted Feb 15, 2022 - 17:30 UTC
Investigating
Cloudflare is observing possible network congestion Across Multiple Regions.

We are working to mitigate impact to Internet users in this region.
Posted Feb 15, 2022 - 17:29 UTC