Cloudflare System Status

Spectrum connectivity issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Oct 02, 2020 - 01:07 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 02, 2020 - 00:58 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 02, 2020 - 00:47 UTC
Investigating
Cloudflare is aware of, and investigating Spectrum connectivity issues.
Posted Oct 02, 2020 - 00:16 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Spectrum).