Cloudflare System Status

Issues passing Challenge Pages and Turnstile

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Mar 25, 2026 - 10:24 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2026 - 08:39 UTC

Investigating

Visitors encountering Turnstile or Cloudflare Challenge Pages are encountering intermittent issues solving the challenge and may have to retry.
Posted Mar 25, 2026 - 07:58 UTC
This incident affected: Cloudflare Sites and Services (Challenge Platform, Turnstile).