Cloudflare System Status

Delays with Log Explorer

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Sep 16, 2025 - 18:11 UTC

Update

We are continuing to work on a fix for this issue.
Posted Sep 16, 2025 - 15:25 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 16, 2025 - 09:35 UTC

Investigating

A small percentage of Log Explorer customer might see delays in recent data being available for querying or experience slower query responses. No logs are being dropped.
Posted Sep 16, 2025 - 09:34 UTC
This incident affected: Cloudflare Sites and Services (Logs).