A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2026 - 13:28 UTC
Identified
Cloudflare is observing possible network congestion in the Eastern America and EU. We are working to mitigate impact to Internet users in these regions.
Posted Apr 14, 2026 - 13:06 UTC
Investigating
Cloudflare is investigating an increased level of HTTP 5xx errors.
We are working to analyse and mitigate this problem. More updates to follow shortly.
Posted Apr 14, 2026 - 12:47 UTC
This incident affects: Cloudflare Sites and Services (Network).