Cloudflare System Status

SSL Certificate Provisioning Delays

Incident Report for Cloudflare

Resolved

Cloudflare has resolved the issue and services have resumed normal operation.
Posted Sep 14, 2023 - 03:41 UTC

Monitoring

Cloudflare has implemented a fix for this issue and is currently monitoring the results.

We will update the status once the issue is resolved.
Posted Sep 14, 2023 - 03:28 UTC

Investigating

Cloudflare is investigating delays in provisioning SSL certificates for Universal SSL, Custom certificates, Cloudflare for SaaS and Advanced Certificate Manager. New SSL certificate provisioning is taking up to 30 minutes.

SSL certificates already in production remain unaffected and are operating normally.

More updates to follow up.
Posted Sep 14, 2023 - 02:47 UTC
This incident affected: Cloudflare Sites and Services (SSL Certificate Provisioning).