Cloudflare System Status

Network Performance Issues in Hong Kong
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Mar 21, 2024 - 09:52 UTC
Monitoring
Cloudflare is aware of network performance issues in Hong Kong (HKG) that occurred between 07:49-08:17 UTC.

A fix has been implemented and we are monitoring the results.
Posted Mar 21, 2024 - 09:42 UTC