Cloudflare System Status

Network Performance Issues in Philadelphia
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jul 16, 2020 - 12:44 UTC
Investigating
Cloudflare is investigating issues with network performance in our Philadelphia datacenter.

We are working to understand the full impact and mitigate this problem. More updates to follow shortly
Posted Jul 16, 2020 - 12:34 UTC
This incident affected: North America (Philadelphia, United States - (PHL)).