Cloudflare System Status

Delayed entitlements after zone upgrade

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Jun 19, 2026 - 12:15 UTC

Identified

We identified a cache invalidation issue delaying changes to customer services and features. We're working on remediation and validating the fix.
Posted Jun 19, 2026 - 11:59 UTC

Investigating

Cloudflare is investigating reports of customers not seeing entitlements after upgrading plans.
Posted Jun 19, 2026 - 11:15 UTC
This incident affected: Cloudflare Sites and Services (Subscriptions).