Cloudflare System Status

Stream Playback Errors

Incident Report for Cloudflare

Update

The team has identified a contributing issue between caching and storage retrieval. An improvement has been released and is being monitored. Additionally, we have adjusted player retry logic to reduce potential stalling. We are continuing our investigation.
Posted Jun 23, 2025 - 23:53 UTC

Monitoring

The team has identified a contributing issue between caching and storage retrieval. A fix has been released and we will be monitoring for improvements while continuing our investigation.
Posted Jun 23, 2025 - 22:07 UTC

Investigating

We are currently investigating reports of intermittent errors impacting Stream on-demand video playback.
Posted Jun 23, 2025 - 18:41 UTC
This incident affects: Cloudflare Sites and Services (Stream).