Cloudflare System Status

Spectrum Availability issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jul 16, 2020 - 05:06 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 16, 2020 - 04:27 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 16, 2020 - 02:22 UTC
Investigating
We are continuing to investigate this issue.
Posted Jul 16, 2020 - 02:04 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 16, 2020 - 01:59 UTC
Investigating
Spectrum applications with TLS termination enabled are experiencing increased connection errors in data centers Kuala Lumpur, Manilla, Jakarta, Toronto and Istanbul. Investigating full impact.
Posted Jul 16, 2020 - 01:53 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Spectrum).