Cloudflare System Status

Network Performance Issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Oct 21, 2019 - 16:51 UTC
Investigating
We are currently investigating this issue.
Posted Oct 21, 2019 - 16:32 UTC
Identified
Cloudflare is observing network performance issues in our Manchester and Marseille locations.

We have identified the issue and are implementing a fix.
Posted Oct 21, 2019 - 16:32 UTC
This incident affected: Europe (Manchester, United Kingdom - (MAN), Marseille, France - (MRS)).