Cloudflare System Status

Certificate Issuance through Google Trust Services Unavailable

Incident Report for Cloudflare

Update

We are continuing to investigate this issue.
Posted Feb 17, 2026 - 21:08 UTC

Update

We are continuing to investigate this issue.
Posted Feb 17, 2026 - 20:54 UTC

Investigating

Google Trust Services is experiencing an unplanned outage: https://status.pki.goog
Posted Feb 17, 2026 - 20:53 UTC
This incident affects: Cloudflare Sites and Services (SSL Certificate Provisioning, SSL for SaaS Provisioning).