Cloudflare System Status

Email Routing deliverability issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Apr 04, 2024 - 13:48 UTC
Monitoring
A fix has been implemented, and email deliverability levels are returning to normal. We are monitoring the results.
Posted Mar 31, 2024 - 16:25 UTC
Update
The team has implemented mitigation improvements. Email Routing deliverability to Gmail accounts is gradually improving to normal levels.
Posted Mar 30, 2024 - 19:35 UTC
Identified
Cloudflare is investigating issues with the Email Routing product relating to degraded deliverability to Gmail accounts.

Impact is restricted to email forwarding functionality, and it does not affect any connectivity, security, CDN or Area1 functionality. In addition, this does not affect delivery to providers other than Gmail.

The problem has been identified and a fix is being implemented.
Posted Mar 29, 2024 - 12:32 UTC
This incident affected: Cloudflare Sites and Services (Email Routing).