Cloudflare System Status

Issue with Updating Worker Usage Model
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted May 06, 2022 - 05:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 06, 2022 - 04:18 UTC
Identified
When updating the Usage Model for a Worker it will lose any Compatibility Date or Flags set on the Worker. This can cause unexpected behavior in the Worker after updating.

Cloudflare has identified the issue and is implementing a fix.

We will update the status once we implement the fix.
Posted May 06, 2022 - 03:24 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Workers).