Cloudflare System Status

Customer Impacting Issue with Teams dashboard
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jun 02, 2021 - 15:59 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 02, 2021 - 15:39 UTC
Investigating
Cloudflare is investigating issues with the Teams dashboard. Customers will not be able to view devices however device registration and connectivity are not impacted.

We are working to understand the full impact and mitigate this problem. More updates to follow shortly.
Posted Jun 02, 2021 - 15:38 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Access, Cloudflare for Teams).