Cloudflare System Status

Customer Impacting Issue in European Region
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Mar 17, 2021 - 18:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 17, 2021 - 17:51 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 17, 2021 - 17:01 UTC
Investigating
Cloudflare is aware of, and investigating an issue which potentially impacts connectivity for multiple customers in the European region. Cloudflare is engaged and working to remediate. Further detail will be provided as more information becomes available.
Posted Mar 17, 2021 - 16:59 UTC
This incident affected: Europe (Hamburg, Germany - (HAM), Helsinki, Finland - (HEL), Tallinn, Estonia - (TLL)).