Cloudflare System Status

Connectivity issues around Manchester, United Kingdom
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Apr 11, 2021 - 22:46 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 11, 2021 - 22:03 UTC
Investigating
We are currently investigating this issue.
Posted Apr 11, 2021 - 21:50 UTC
This incident affected: Europe (Manchester, United Kingdom - (MAN)).