Cloudflare System Status

Connectivity Issues when using Zero Trust Gateway Egress and Network Policies

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 18:03 UTC

Monitoring

A fix has been implemented and we are currently monitoring the results.
Posted Oct 28, 2025 - 17:29 UTC

Identified

Cloudflare has identified an issue causing connectivity problems for a subset of Cloudflare One customers when the traffic requires Zero Trust Gateway Egress (specifically with Hostname selector) or Network policies. We are currently working on applying a fix.
Posted Oct 28, 2025 - 16:53 UTC
This incident affected: Cloudflare Sites and Services (Gateway).