Cloudflare System Status

Cloudflare Images Degraded Upload Performance
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Mar 17, 2022 - 17:54 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 17, 2022 - 17:27 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 17, 2022 - 16:57 UTC
Update
We are continuing to investigate this issue.
Posted Mar 17, 2022 - 16:11 UTC
Investigating
Cloudflare is investigating reports of uploads to Cloudflare Images, and an increase in reported 5xx Errors. There is no impact to the delivery of images.
Posted Mar 17, 2022 - 16:11 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Images).