Cloudflare System Status

Intermittent Failures in Browser Isolation

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 00:18 UTC

Monitoring

We have identified and implemented a fix for this issue and are currently monitoring the results.
Posted Apr 22, 2025 - 23:58 UTC

Investigating

Some users are experiencing intermittent failures to acquire a remote browser. The team is investigating.
Posted Apr 22, 2025 - 23:49 UTC
This incident affected: Cloudflare Sites and Services (Browser Isolation).