Cloudflare System Status

DNS Propagation Delays
Incident Report for Cloudflare
Resolved
Cloudflare has resolved the issue and DNS propagation times have returned to normal.
Posted 3 months ago. Nov 29, 2018 - 01:07 UTC
Monitoring
Cloudflare has implemented a fix for this issue and is currently monitoring the results.

We will update the status once the issue is resolved.
Posted 3 months ago. Nov 28, 2018 - 19:30 UTC
Investigating
Cloudflare is investigating delays in updates to DNS records. These delays affect record changes and updates.

DNS resolution is operating with increased latency.
Posted 3 months ago. Nov 28, 2018 - 19:30 UTC