Cloudflare System Status

Network Performance Issues in North America
Incident Report for Cloudflare
Resolved
This issue has been resolved and services have returned to normal.
Posted 3 months ago. Jul 01, 2018 - 04:01 UTC
Identified
The issue has been identified and a fix is being implemented. We will update once we have confirmed it is working.
Posted 3 months ago. Jul 01, 2018 - 03:39 UTC
Investigating
Cloudflare is observing network performance issues in North America. We are actively working to reduce or eliminate any impact to Internet users in this region.
Posted 3 months ago. Jul 01, 2018 - 03:19 UTC
This incident affected: North America (Tampa, FL, United States - (TPA)).