Cloudflare System Status

Billing Errors - managing payment methods, subscriptions, paying invoices & inaccurate unpaid balances
Incident Report for Cloudflare
Update
Remediation for customers with missing invoices is ongoing. We anticipate it to complete by the end of day Monday, April 29.

If you require URGENT assistance, please raise a Support ticket or amend your existing ticket via the Cloudflare Dashboard, and we can help look into your account specific details.
Posted Apr 26, 2024 - 23:06 UTC
Update
Remediation for customers with missing invoices is in progress. We anticipate it to complete by the end of day Friday, April 26.

If you require URGENT assistance, please raise a Support ticket or amend your existing ticket via the Cloudflare Dashboard, and we can help look into your account specific details.
Posted Apr 25, 2024 - 23:29 UTC
Update
The team has removed the maintenance hold on all accounts.

Work to address difficulties paying off old balances has been completed.

Our work to resolve missing invoices for some customers is continuing and expected to be resolved by early next week.

Customers that were seeing unknown charges on invoices or have been incorrectly downgraded will have credits applied on their accounts in the next few days and will be notified via email when it is completed.

If you require URGENT assistance, please raise a Support ticket or amend your existing ticket via the Cloudflare Dashboard, and we can help look into your account specific details.
Posted Apr 19, 2024 - 15:43 UTC
Update
The team has removed the maintenance hold on all accounts.

Work to address difficulties paying off old balances has also now been completed.

Our work to find long term solutions for cases where customers are missing invoices, seeing unknown charges on invoices or have been incorrectly downgraded plans is continuing.

If you require URGENT assistance, please raise a Support ticket or amend your existing ticket via the Cloudflare Dashboard, and we can help look into your account specific details.
Posted Apr 12, 2024 - 07:47 UTC
Update
The team is currently removing maintenance hold on all accounts.

Separately, our work to find long term solutions for customers who are experiencing difficulties paying off old balances, seeing unknown charges on invoices or have been incorrectly downgraded plans are in progress.

If you require URGENT assistance, please raise a Support ticket or amend your existing ticket via the Cloudflare Dashboard, and we can help look into your account specific details.
Posted Apr 10, 2024 - 01:19 UTC
Update
The team is currently removing maintenance holds on all accounts.

Separately, our work to find long term solutions for customers who are experiencing difficulties seeing unknown charges on invoices or have had incorrectly downgraded plans are in progress.

If you require URGENT assistance, please raise a Support ticket or amend your existing ticket via the Cloudflare Dashboard, and we can help look into your account specific details.
Posted Apr 09, 2024 - 16:08 UTC
Update
We have identified separate root causes for some of the issues.
The team are now 80% through clearing the list of accounts blocked under maintenance hold. Accounts released from maintenance hold will return to having full billing and upgrading/downgrading functionality.

We are working, in parallel, to a solution for customers who are experiencing issues such as being incorrectly labeled as banned or bad debt, have missing or inaccurate invoices or have been incorrectly downgraded plans.

As we complete this work, impacted customers may continue to be unable to make changes to their billing account profile, including updating payment methods, billing addresses, or adding/upgrading/downgrading subscription plans. Additionally, they may face challenges in paying invoices and may see erroneous warnings about unpaid invoices. No other functionality of the Cloudflare platform is impacted, and our team is working on resolving this as soon as possible.

If you require URGENT assistance, please raise a Support ticket via the Cloudflare Dashboard, and we can help look into your account specific details.
Posted Apr 05, 2024 - 16:04 UTC
Update
The team are now working through each impacted account and removing any holds or blocks.

As we complete this work, impacted customers may continue to be unable to make changes to their billing account profile, including updating payment methods, billing addresses, or adding/upgrading/downgrading subscription plans. Additionally, they may face challenges in paying invoices and may see erroneous warnings about unpaid invoices. No other functionality of the Cloudflare platform is impacted and our team is working on resolving this as soon as possible.

If you require URGENT assistance, please raise a Support ticket via the Cloudflare Dashboard, and we can help look into your account specific details.
Posted Apr 03, 2024 - 16:31 UTC
Identified
The issue with the billing system has been identified, and our billing team is working on a permanent resolution.

Impacted customers may temporarily be unable to make changes to their billing account profile, including updating payment methods, billing addresses, or adding/upgrading/downgrading subscription plans. Additionally, they may face challenges in paying invoices and may see erroneous warnings about unpaid invoices. No other functionality of the Cloudflare platform is impacted, and our team is working on resolving this as soon as possible.

If you are impacted by this, we can help. Please raise a Support ticket via the Cloudflare Dashboard if you require urgent assistance with any billing or subscription related matter.
Posted Mar 28, 2024 - 21:15 UTC
Update
We are continuing to investigate this issue.
Posted Mar 28, 2024 - 15:53 UTC
Update
We are continuing to investigate this issue.
Posted Mar 27, 2024 - 19:35 UTC
Update
We are continuing to investigate this issue.
Posted Mar 25, 2024 - 00:02 UTC
Update
We are continuing to investigate this issue.
Posted Mar 24, 2024 - 08:07 UTC
Update
We are continuing to investigate this issue.
Posted Mar 23, 2024 - 15:34 UTC
Update
We are continuing to investigate this issue.
Posted Mar 23, 2024 - 04:25 UTC
Update
Work continues on-track towards a resolution
Posted Mar 21, 2024 - 08:05 UTC
Investigating
Some customers may not be able to make changes to their billing account profile, including updating payment methods, billing addresses, or adding/upgrading/downgrading subscription plans. Additionally, they may face challenges in paying invoices, and may see erroneous warnings about unpaid invoices.

These customer accounts may also be downgraded temporarily, unable to add new sites, and unable to purchase/transfer/renew domains.

No action is required for customers facing these issues for the time being
An automated clean-up process will take place to correct any incorrect categorisation.
Posted Mar 21, 2024 - 00:46 UTC
This incident affects: Cloudflare Sites and Services (Billing).