Cloudflare System Status

Network Analytics Delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Mar 14, 2024 - 19:34 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 14, 2024 - 18:33 UTC
Identified
Cloudflare Network Analytics processing is running behind. This affects timely delivery of customer analytics data. We are working to mitigate this problem. More updates to follow shortly.
Posted Mar 14, 2024 - 18:07 UTC
This incident affected: Cloudflare Sites and Services (Analytics).