Cloudflare System Status

Network Performance Issues in Helsinki (HEL)
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Apr 24, 2024 - 15:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 24, 2024 - 15:03 UTC
Investigating
Cloudflare is investigating issues with Network Performance

We are working to analyze and mitigate this problem. More updates to follow shortly.
Posted Apr 24, 2024 - 14:49 UTC
This incident affected: Europe (Helsinki, Finland - (HEL)).