Cloudflare System Status

Slow Response Times in Eastern Europe
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Apr 12, 2024 - 14:22 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 12, 2024 - 13:39 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 12, 2024 - 13:27 UTC
Update
We are continuing to investigate this issue.
Posted Apr 12, 2024 - 12:21 UTC
Investigating
Cloudflare is aware of a general latency or connectivity issues for traffic going through Athens.
Posted Apr 12, 2024 - 08:41 UTC
This incident affected: Europe (Athens, Greece - (ATH)).