Cloudflare System Status

Cloudflare Service Issues - EMEA Region
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted May 26, 2023 - 15:38 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 26, 2023 - 15:19 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 26, 2023 - 14:24 UTC
Investigating
Cloudflare is investigating wide-spread issues with our services and/or network within the EMEA region

Users may experience errors or timeouts reaching Cloudflare’s network or services.

We will update this status page to clarify the scope of impact as we continue the investigation.

The next update should be expected within 15 minutes.
Posted May 26, 2023 - 14:18 UTC
This incident affected: Cloudflare Sites and Services (Infrastructure, Network).