Cloudflare System Status

Cloudflare for SaaS Custom hostname activation delays
Incident Report for Cloudflare
Resolved
The custom hostname verification delay occurred between 10:42 UTC to 11:10 UTC. This incident is now resolved
Posted May 31, 2023 - 11:51 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 31, 2023 - 11:28 UTC
Identified
Cloudflare for SaaS custom hostnames is incurring verification delays since 10:50 UTC. R2, Pages and Workers with custom domains are impacted. The issue has been identified and we are actively working to resolve the issue.
Posted May 31, 2023 - 11:07 UTC
This incident affected: Cloudflare Sites and Services (SSL Certificate Provisioning).