Cloudflare System Status

Increase in challenges for traffic from Tor exit nodes
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Mar 22, 2023 - 22:34 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 22, 2023 - 22:05 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 22, 2023 - 19:33 UTC
Investigating
Cloudflare is investigating an increase in challenges for traffic originating from Tor exit nodes. Some visitors may also be misidentified as Tor traffic.
Posted Mar 22, 2023 - 18:03 UTC
This incident affected: Cloudflare Sites and Services (Firewall, Turnstile).