Cloudflare System Status

Network Performance Issues in Manchester, GB
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Sep 30, 2022 - 15:26 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 30, 2022 - 14:10 UTC
Investigating
Cloudflare is investigating issues with network performance in Manchester, GB.

We are working to analyze and mitigate this problem. More updates to follow shortly.
Posted Sep 30, 2022 - 13:54 UTC
This incident affected: Europe (Manchester, United Kingdom - (MAN)).