Cloudflare system status
SSL Certificate Provisioning Delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted about 1 month ago. May 24, 2018 - 15:42 UTC
Monitoring
We have implemented a fix for this issue and are currently monitoring the results. We will update once we have confirmed it is resolved.

Please note delays will still be noted while the backlog for the issue is cleared by the implemented fix.
Posted about 1 month ago. May 24, 2018 - 08:53 UTC
Investigating
Cloudflare is investigating SSL Certificate Provisioning Delays

We are observing delays of up to 2 hours in provisioning new SSL Certificates. Cloudflare's TLS/SSL service is still available; only provisioning of new SSL Certificates is delayed.

Note this affects our Custom Hostname, Partner Universal SSL and Dedicated SSL certificates issuance only. This specific issue can also trigger 504 errors in the Cloudflare dashboard.
Posted about 1 month ago. May 24, 2018 - 08:51 UTC
This incident affected: Cloudflare customer dashboard and APIs (SSL Certificates).